Carrier Issues- DHL Carrier Services Unavailable

Incident Report for ShipStation

Resolved

This incident has been resolved.
Posted Apr 21, 2025 - 13:36 CDT

Investigating

ShipStation is aware of the technical issues impacting some DHL services. We are actively monitoring the status of these issues and will provide updates as they become available.

Thank you for your patience!
Posted Apr 21, 2025 - 08:57 CDT
This incident affected: Carriers (DHL eCommerce).