Canadian Union of Postal Workers Strike Updates
Incident Report for ShipStation
Resolved
This incident has been resolved.
Posted Jan 17, 2025 - 16:49 CST
Update
Global Carrier Update

Effective January 15, 2025, Australia Post will resume full service to Canada and start accepting packages again. Starting January 15, 2025, you can create and print labels destined for Canada using your account.

NZPost resumed full service to Canada and is now accepting mail and packages again. You can now create and print labels destined for Canada using your ShipStation account.

Effective Monday, December 30, 2025, Royal Mail resumed full service to Canada and is now accepting mail and packages again. You can now create and print labels destined for Canada using your ShipStation account.

Please remember that due to the recent CUPW strike and accumulated backlog, shipments may experience delays.

Sendle from ShipStation:
Effective Friday, December 6, 2024, Sendle will require customers to enter package dimensions when creating a Sendle label in ShipStation. Sendle continues to accept packages with a destination of Canada at this time.

GlobalPost (North America):
Effective Monday, January 6, 2025, GlobalPost has resumed full service to Canada, including P.O. Boxes and previously restricted postal codes, and is now accepting mail and packages again for these destinations.

More detailed information is available at the carrier websites below:

USPS: https://about.usps.com/newsroom/service-alerts/international/welcome.htm

Australia Post: https://auspost.com.au/disruptions-and-updates/international-service-updates

NZ Post: https://www.nzpost.co.nz/contact-support/international-delivery-updates#sending

Canada Post: https://www.canadapost-postescanada.ca/cpc/en/our-company/news-and-media/corporate-news/negotiations-list.page

Royal Mail: https://www.royalmail.com/international-incident-bulletin

GlobalPost: https://www.goglobalpost.com/blog/navigating-shipping-challenges-during-the-cupw-strike/

-------------------------------------------------------------------------------------------------------------------------------------------------------------

Canadian Carrier Update

Canada Post:
Effective December 17, 2024, Canada Post resumed operations and will be accepting new mail and parcels on December 19, 2024. Starting December 19th, you can create and print Canada Post labels using your ShipStation account.

https://www.canadapost-postescanada.ca/cpc/en/our-company/news-and-media/corporate-news/negotiations/2024-12-16-resuming-operations-important-information-for-customers

UPS from ShipStation:
Effective Monday, January 6, 2025, all UPS On-Call Pickup requests for Domestic Standard shipments in Canada are now available.

Purolator from ShipStation:
Effective Friday, January 3, 2025, Purolator has resumed full service across all available Canadian ZIP Codes and is now accepting packages for these destinations.

GlobalPost from ShipStation:
Effective Monday, January 6, 2025, GlobalPost has resumed full service to Canada, including P.O. Boxes and previously restricted postal codes, and is now accepting mail and packages again for these destinations.

FedEx from ShipStation:
No changes at this time.

DHL Express from ShipStation:
No changes at this time.

Canpar from ShipStation:
No changes at this time.

Sendle from ShipStation:
Effective Friday, December 6, 2024, Sendle will require customers to enter package dimensions when creating a Sendle label in ShipStation. Sendle continues to accept packages with a destination of Canada at this time.

-------------------------------------------------------------------------------------------------------------------------------------------------------------

U.S. Carrier Update

USPS:

Effective Monday, January 6, 2025, USPS will resume full service to Canada and begin accepting mail and packages again. Starting Monday, January 6, 2025, you can create and print USPS labels destined for Canada using your ShipStation account. Please note that due to the recent CUPW strike and accumulated backlog, shipments may experience delays.

GlobalPost from ShipStation:
Effective Monday, January 6, 2025, GlobalPost has resumed full service to Canada, including P.O. Boxes and previously restricted postal codes, and is now accepting mail and packages again for these destinations.

Sendle:
Effective Friday, December 6, 2024, Sendle will require customers to enter package dimensions when creating a Sendle label in ShipStation. Sendle continues to accept packages with a destination of Canada at this time.
Posted Dec 20, 2024 - 09:00 CST
Update
We are continuing to monitor.
Posted Dec 06, 2024 - 18:05 CST
Update
We are continuing to monitor.
Posted Nov 27, 2024 - 21:04 CST
Update
We are continuing to monitor.
Posted Nov 27, 2024 - 17:32 CST
Monitoring
Effective November 29, 2024, the Postal Service™ will temporarily suspend international mail acceptance to Canada due to the foreign postal operator indicating that they are unable to process or deliver international mail or services because of the ongoing national strike by the Canadian Union of Postal Workers. Customers are asked to refrain from mailing items addressed to the following country, until further notice: Canada

This service disruption affects Priority Mail Express International® (PMEI), Priority Mail International® (PMI), First-Class Mail International® (FCMI), First-Class Package International Service® (FCPIS), International Priority Airmail® (IPA), International Surface Air Lift® (ISAL), Commercial ePacket® (CeP), and M-Bag® items.
Posted Nov 15, 2024 - 13:11 CST
This incident affected: Carriers (Canada Post).